index
:
aria2
HEAD
diskspace
dynamic-select-file
libaria2
random-webseeding
rearrange-args
refactor-wintls-write
release-1.26.x
release-1.33.x
utp-support
Aria2 download utility with uTP support
Nagi
summary
refs
log
tree
commit
diff
log msg
author
committer
range
path:
root
/
test
/
UtilTest.cc
Commit message (
Expand
)
Author
Age
Files
Lines
*
util::percentEncodeMini: Fix regression bug removed unsignedness
Tatsuhiro Tsujikawa
2013-09-30
1
-0
/
+8
*
Rewrite util::divide
Tatsuhiro Tsujikawa
2013-06-25
1
-6
/
+5
*
Remove vbegin and vend in favor of std::begin and std::end
Tatsuhiro Tsujikawa
2013-06-24
1
-5
/
+8
*
Require -std=c++11 and use std::shared_ptr instead of SharedHandle
Tatsuhiro Tsujikawa
2013-06-22
1
-5
/
+5
*
Accept k and m as well as K and M in util::getRealSize()
Tatsuhiro Tsujikawa
2013-01-15
1
-0
/
+2
*
Changed threshold of using upper unit for abbrevSize
Tatsuhiro Tsujikawa
2012-12-19
1
-2
/
+1
*
Compact readout when more than 1 simultaneous downloads are going on
Tatsuhiro Tsujikawa
2012-12-11
1
-5
/
+8
*
Made return type of util::parse_content_disposition ssize_t
Tatsuhiro Tsujikawa
2012-11-01
1
-91
/
+91
*
Content-Disposition parser conforming to RFC 6266.
Tatsuhiro Tsujikawa
2012-10-27
1
-104
/
+606
*
Removed trailing spaces
Tatsuhiro Tsujikawa
2012-10-01
1
-5
/
+5
*
Removed unused functions
Tatsuhiro Tsujikawa
2012-09-27
1
-22
/
+0
*
Use nothrow version of parseInt, parseUInt and parseLLInt
Tatsuhiro Tsujikawa
2012-09-27
1
-100
/
+0
*
Made BufferedFile ctor take const char* args
Tatsuhiro Tsujikawa
2012-09-25
1
-1
/
+1
*
Don't percent-decode filename value in Content-Disposition.
Tatsuhiro Tsujikawa
2012-06-28
1
-1
/
+3
*
Rewritten TLS hostname check based on RFC 6125.
Tatsuhiro Tsujikawa
2012-03-30
1
-18
/
+17
*
Added hostname check described in RFC 2818 with OpenSSL.
Tatsuhiro Tsujikawa
2012-03-28
1
-0
/
+27
*
Avoid strlen in util::streq, util::strieq, util::startsWith and util::istarts...
Tatsuhiro Tsujikawa
2012-01-11
1
-0
/
+20
*
Removed static const char[] as much as possible.
Tatsuhiro Tsujikawa
2012-01-11
1
-30
/
+16
*
Replaced uint64_t with off_t or int64_t.
Tatsuhiro Tsujikawa
2011-12-09
1
-22
/
+0
*
Changed format of ETA.
Tatsuhiro Tsujikawa
2011-11-13
1
-0
/
+15
*
Don't append character to std::string.
Tatsuhiro Tsujikawa
2011-11-12
1
-0
/
+15
*
Rewritten parse*Int
Tatsuhiro Tsujikawa
2011-11-12
1
-39
/
+39
*
HttpHeader::fill() now stores header name in lowercase.
Tatsuhiro Tsujikawa
2011-11-11
1
-0
/
+18
*
Rewritten parametered URI handling routine.
Tatsuhiro Tsujikawa
2011-11-06
1
-15
/
+30
*
Made util::fromHex and base32::decode function template
Tatsuhiro Tsujikawa
2011-11-05
1
-22
/
+22
*
Rewritten bencode2::decode functions
Tatsuhiro Tsujikawa
2011-11-05
1
-1
/
+1
*
Added util::istartsWith()
Tatsuhiro Tsujikawa
2011-11-05
1
-0
/
+17
*
Removed util::endsWith(a, b). Added util::iendsWith()
Tatsuhiro Tsujikawa
2011-11-05
1
-8
/
+14
*
Removed util::startsWith(a, b)
Tatsuhiro Tsujikawa
2011-11-04
1
-7
/
+0
*
Rewritten util::split and added its iterator version.
Tatsuhiro Tsujikawa
2011-11-04
1
-14
/
+383
*
util::divide now takes iterators as arguments.
Tatsuhiro Tsujikawa
2011-11-03
1
-16
/
+35
*
util::percentDecode now takes iterators as arguments.
Tatsuhiro Tsujikawa
2011-11-03
1
-6
/
+11
*
Changed parse*Int functions so that it accepts iterators.
Tatsuhiro Tsujikawa
2011-11-03
1
-40
/
+124
*
Rewritten parseIndexPath. Renamed createIndexPathMap as createIndexPaths.
Tatsuhiro Tsujikawa
2011-11-02
1
-9
/
+9
*
Removed IntSequence and Sequence<T>
Tatsuhiro Tsujikawa
2011-10-30
1
-62
/
+0
*
Use SegList<int> instead of IntSequence in DownloadContext::setFileFilter()
Tatsuhiro Tsujikawa
2011-10-29
1
-0
/
+75
*
Use same domain-match algorithm for no-proxy and netrc.
Tatsuhiro Tsujikawa
2011-10-29
1
-0
/
+13
*
Rewritten util::inSameCidrBlock() to support IPv6 address.
Tatsuhiro Tsujikawa
2011-10-19
1
-25
/
+10
*
Fixed output file path of tests.
Tatsuhiro Tsujikawa
2011-08-25
1
-1
/
+1
*
Use global::cout to output string to stdout.
Tatsuhiro Tsujikawa
2011-08-09
1
-2
/
+7
*
Added Metalink/HTTP Link and Digest header field parser.
Tatsuhiro Tsujikawa
2011-07-26
1
-0
/
+40
*
Moved joinUri from util namespace to uri namespace.
Tatsuhiro Tsujikawa
2011-05-06
1
-50
/
+0
*
Handle "..", "." in util::joinUri()
Tatsuhiro Tsujikawa
2011-04-30
1
-0
/
+27
*
Added util::joinUri()
Tatsuhiro Tsujikawa
2011-04-30
1
-0
/
+23
*
Made `make distcheck' pass.
Tatsuhiro Tsujikawa
2010-12-02
1
-1
/
+1
*
2010-11-15 Tatsuhiro Tsujikawa <t-tujikawa@users.sourceforge.net>
Tatsuhiro Tsujikawa
2010-11-15
1
-0
/
+18
*
2010-10-10 Tatsuhiro Tsujikawa <t-tujikawa@users.sourceforge.net>
Tatsuhiro Tsujikawa
2010-10-10
1
-27
/
+80
*
2010-10-10 Tatsuhiro Tsujikawa <t-tujikawa@users.sourceforge.net>
Tatsuhiro Tsujikawa
2010-10-10
1
-9
/
+9
*
2010-10-10 Tatsuhiro Tsujikawa <t-tujikawa@users.sourceforge.net>
Tatsuhiro Tsujikawa
2010-10-10
1
-0
/
+18
*
2010-10-10 Tatsuhiro Tsujikawa <t-tujikawa@users.sourceforge.net>
Tatsuhiro Tsujikawa
2010-10-09
1
-0
/
+24
[next]