summaryrefslogtreecommitdiff
path: root/test/UtilTest.cc
Commit message (Expand)AuthorAgeFilesLines
* Split UtilTest.cc into UtilTest1.cc and UtilTest2.ccTatsuhiro Tsujikawa2015-02-081-2303/+0
* Remove some left-over code from converting a test.Nils Maier2015-01-261-4/+0
* Revise getRandom facilitiesNils Maier2015-01-201-2/+46
* util::parseIntSegments: Return SegList<int>Tatsuhiro Tsujikawa2014-06-041-39/+34
* util::percentEncodeMini: Fix regression bug removed unsignednessTatsuhiro Tsujikawa2013-09-301-0/+8
* Rewrite util::divideTatsuhiro Tsujikawa2013-06-251-6/+5
* Remove vbegin and vend in favor of std::begin and std::endTatsuhiro Tsujikawa2013-06-241-5/+8
* Require -std=c++11 and use std::shared_ptr instead of SharedHandleTatsuhiro Tsujikawa2013-06-221-5/+5
* Accept k and m as well as K and M in util::getRealSize()Tatsuhiro Tsujikawa2013-01-151-0/+2
* Changed threshold of using upper unit for abbrevSizeTatsuhiro Tsujikawa2012-12-191-2/+1
* Compact readout when more than 1 simultaneous downloads are going onTatsuhiro Tsujikawa2012-12-111-5/+8
* Made return type of util::parse_content_disposition ssize_tTatsuhiro Tsujikawa2012-11-011-91/+91
* Content-Disposition parser conforming to RFC 6266.Tatsuhiro Tsujikawa2012-10-271-104/+606
* Removed trailing spacesTatsuhiro Tsujikawa2012-10-011-5/+5
* Removed unused functionsTatsuhiro Tsujikawa2012-09-271-22/+0
* Use nothrow version of parseInt, parseUInt and parseLLIntTatsuhiro Tsujikawa2012-09-271-100/+0
* Made BufferedFile ctor take const char* argsTatsuhiro Tsujikawa2012-09-251-1/+1
* Don't percent-decode filename value in Content-Disposition.Tatsuhiro Tsujikawa2012-06-281-1/+3
* Rewritten TLS hostname check based on RFC 6125.Tatsuhiro Tsujikawa2012-03-301-18/+17
* Added hostname check described in RFC 2818 with OpenSSL.Tatsuhiro Tsujikawa2012-03-281-0/+27
* Avoid strlen in util::streq, util::strieq, util::startsWith and util::istarts...Tatsuhiro Tsujikawa2012-01-111-0/+20
* Removed static const char[] as much as possible.Tatsuhiro Tsujikawa2012-01-111-30/+16
* Replaced uint64_t with off_t or int64_t.Tatsuhiro Tsujikawa2011-12-091-22/+0
* Changed format of ETA.Tatsuhiro Tsujikawa2011-11-131-0/+15
* Don't append character to std::string.Tatsuhiro Tsujikawa2011-11-121-0/+15
* Rewritten parse*IntTatsuhiro Tsujikawa2011-11-121-39/+39
* HttpHeader::fill() now stores header name in lowercase.Tatsuhiro Tsujikawa2011-11-111-0/+18
* Rewritten parametered URI handling routine.Tatsuhiro Tsujikawa2011-11-061-15/+30
* Made util::fromHex and base32::decode function templateTatsuhiro Tsujikawa2011-11-051-22/+22
* Rewritten bencode2::decode functionsTatsuhiro Tsujikawa2011-11-051-1/+1
* Added util::istartsWith()Tatsuhiro Tsujikawa2011-11-051-0/+17
* Removed util::endsWith(a, b). Added util::iendsWith()Tatsuhiro Tsujikawa2011-11-051-8/+14
* Removed util::startsWith(a, b)Tatsuhiro Tsujikawa2011-11-041-7/+0
* Rewritten util::split and added its iterator version.Tatsuhiro Tsujikawa2011-11-041-14/+383
* util::divide now takes iterators as arguments.Tatsuhiro Tsujikawa2011-11-031-16/+35
* util::percentDecode now takes iterators as arguments.Tatsuhiro Tsujikawa2011-11-031-6/+11
* Changed parse*Int functions so that it accepts iterators.Tatsuhiro Tsujikawa2011-11-031-40/+124
* Rewritten parseIndexPath. Renamed createIndexPathMap as createIndexPaths.Tatsuhiro Tsujikawa2011-11-021-9/+9
* Removed IntSequence and Sequence<T>Tatsuhiro Tsujikawa2011-10-301-62/+0
* Use SegList<int> instead of IntSequence in DownloadContext::setFileFilter()Tatsuhiro Tsujikawa2011-10-291-0/+75
* Use same domain-match algorithm for no-proxy and netrc.Tatsuhiro Tsujikawa2011-10-291-0/+13
* Rewritten util::inSameCidrBlock() to support IPv6 address.Tatsuhiro Tsujikawa2011-10-191-25/+10
* Fixed output file path of tests.Tatsuhiro Tsujikawa2011-08-251-1/+1
* Use global::cout to output string to stdout.Tatsuhiro Tsujikawa2011-08-091-2/+7
* Added Metalink/HTTP Link and Digest header field parser.Tatsuhiro Tsujikawa2011-07-261-0/+40
* Moved joinUri from util namespace to uri namespace.Tatsuhiro Tsujikawa2011-05-061-50/+0
* Handle "..", "." in util::joinUri()Tatsuhiro Tsujikawa2011-04-301-0/+27
* Added util::joinUri()Tatsuhiro Tsujikawa2011-04-301-0/+23
* Made `make distcheck' pass.Tatsuhiro Tsujikawa2010-12-021-1/+1
* 2010-11-15 Tatsuhiro Tsujikawa <t-tujikawa@users.sourceforge.net>Tatsuhiro Tsujikawa2010-11-151-0/+18