summaryrefslogtreecommitdiff
path: root/src/util.h
Commit message (Expand)AuthorAgeFilesLines
* Set sa_mask when setting signal handlerTatsuhiro Tsujikawa2013-02-141-1/+6
* Rewritten util::uitos()Tatsuhiro Tsujikawa2013-01-161-16/+19
* Made return type of util::parse_content_disposition ssize_tTatsuhiro Tsujikawa2012-11-011-3/+3
* Content-Disposition parser conforming to RFC 6266.Tatsuhiro Tsujikawa2012-10-271-1/+30
* Removed unused functionsTatsuhiro Tsujikawa2012-09-271-16/+0
* Use nothrow version of parseInt, parseUInt and parseLLIntTatsuhiro Tsujikawa2012-09-271-3/+0
* Made DEFAULT_STRIP_CHARSET const char[]Tatsuhiro Tsujikawa2012-09-241-13/+9
* Store only interesting HTTP headers in HttpHeaderTatsuhiro Tsujikawa2012-09-231-0/+3
* Rewritten DownloadHandlerConstantsTatsuhiro Tsujikawa2012-09-221-3/+3
* Use int64_t instead of off_tTatsuhiro Tsujikawa2012-06-251-1/+1
* Rewritten HTTP header parserTatsuhiro Tsujikawa2012-06-231-0/+4
* Don't use locale dependent toupper and tolower.Tatsuhiro Tsujikawa2012-03-311-0/+4
* Rewritten TLS hostname check based on RFC 6125.Tatsuhiro Tsujikawa2012-03-301-16/+1
* Added hostname check described in RFC 2818 with OpenSSL.Tatsuhiro Tsujikawa2012-03-281-0/+18
* Fixed clang warning and errors.Tatsuhiro Tsujikawa2012-03-011-47/+47
* Check scheme part in redirected URI more strictly.Tatsuhiro Tsujikawa2012-02-151-0/+2
* Avoid strlen in util::streq, util::strieq, util::startsWith and util::istarts...Tatsuhiro Tsujikawa2012-01-111-4/+26
* Use short form of util::startsWith and util::endsWithTatsuhiro Tsujikawa2012-01-111-0/+1
* Removed static const char[] as much as possible.Tatsuhiro Tsujikawa2012-01-111-7/+41
* Fixed compile error on android (which does not LFS support)Tatsuhiro Tsujikawa2011-12-261-1/+1
* Use int instead of unsigned int where unsigned int is not needed.Tatsuhiro Tsujikawa2011-12-091-1/+1
* Replaced uint64_t with off_t or int64_t.Tatsuhiro Tsujikawa2011-12-091-5/+1
* Don't append character to std::string.Tatsuhiro Tsujikawa2011-11-121-1/+1
* Rewritten parse*IntTatsuhiro Tsujikawa2011-11-121-165/+10
* HttpHeader::fill() now stores header name in lowercase.Tatsuhiro Tsujikawa2011-11-111-0/+10
* Code cleanupTatsuhiro Tsujikawa2011-11-081-16/+16
* Rewritten parametered URI handling routine.Tatsuhiro Tsujikawa2011-11-061-6/+42
* Made util::fromHex and base32::decode function templateTatsuhiro Tsujikawa2011-11-051-4/+24
* Rewritten bencode2::decode functionsTatsuhiro Tsujikawa2011-11-051-6/+7
* Added util::istartsWith()Tatsuhiro Tsujikawa2011-11-051-2/+14
* Removed util::endsWith(a, b). Added util::iendsWith()Tatsuhiro Tsujikawa2011-11-051-4/+14
* Rewritten util::split and added its iterator version.Tatsuhiro Tsujikawa2011-11-041-18/+170
* util::divide now takes iterators as arguments.Tatsuhiro Tsujikawa2011-11-031-1/+15
* util::percentDecode now takes iterators as arguments.Tatsuhiro Tsujikawa2011-11-031-1/+2
* Changed parse*Int functions so that it accepts iterators.Tatsuhiro Tsujikawa2011-11-031-8/+169
* Rewritten util::stripIter(), which now returns pair of iterator.Tatsuhiro Tsujikawa2011-11-031-16/+20
* Rewritten parseIndexPath. Renamed createIndexPathMap as createIndexPaths.Tatsuhiro Tsujikawa2011-11-021-2/+2
* Removed IntSequence and Sequence<T>Tatsuhiro Tsujikawa2011-10-301-3/+0
* Use SegList<int> instead of IntSequence in DownloadContext::setFileFilter()Tatsuhiro Tsujikawa2011-10-291-0/+3
* Use same domain-match algorithm for no-proxy and netrc.Tatsuhiro Tsujikawa2011-10-291-0/+11
* Don't copy Option in RequestGroup ctor.Tatsuhiro Tsujikawa2011-10-251-0/+6
* Rewritten Option. Introduced Pref.Tatsuhiro Tsujikawa2011-10-211-2/+3
* Rewritten util::inSameCidrBlock() to support IPv6 address.Tatsuhiro Tsujikawa2011-10-191-6/+7
* Use global::cout to output string to stdout.Tatsuhiro Tsujikawa2011-08-091-10/+14
* Percent-encode non-printable ASCII and non-ASCII chars in FileEntry.Tatsuhiro Tsujikawa2011-08-071-0/+2
* In MinGW32, open file with UNICODE filename and print them in ANSI.Tatsuhiro Tsujikawa2011-08-041-1/+15
* Added Metalink/HTTP Link and Digest header field parser.Tatsuhiro Tsujikawa2011-07-261-0/+54
* Remove Metalink content-type after first server response.Tatsuhiro Tsujikawa2011-07-251-0/+1
* Moved joinUri from util namespace to uri namespace.Tatsuhiro Tsujikawa2011-05-061-2/+0
* Added util::joinUri()Tatsuhiro Tsujikawa2011-04-301-0/+2