summaryrefslogtreecommitdiff
path: root/src/util.h
Commit message (Expand)AuthorAgeFilesLines
* Implement a somewhat compatible std::experimental::filesystem::spaceNils Maier2016-12-171-0/+19
* Allow subsecond value in ns cookie.txt file's expiry time fieldTatsuhiro Tsujikawa2016-05-151-0/+4
* mingw: Defer the falloc warning until falloc is specified by optionTatsuhiro Tsujikawa2016-04-181-0/+4
* Don't inherit file descriptor to child processTatsuhiro Tsujikawa2016-02-081-0/+5
* mingw: Add formatLastError as wrapper function for FormatMessageTatsuhiro Tsujikawa2016-01-281-0/+7
* Refactor HttpRequestTatsuhiro Tsujikawa2016-01-101-0/+1
* Refactor SocketCore::getPeerInfo, getAddrInfo to return Endpoint objectTatsuhiro Tsujikawa2016-01-091-2/+1
* make clang-format using clang-format-3.6Tatsuhiro Tsujikawa2015-12-271-233/+198
* Remove unused macros defined in util.hTatsuhiro Tsujikawa2015-06-211-8/+0
* Use std::make_sharedTatsuhiro Tsujikawa2015-06-111-1/+1
* Make config and cache files conform to XDGVasilij Schneidermann2015-06-021-0/+7
* Mingw: Use _wgetenv to get user's home directoryTatsuhiro Tsujikawa2015-02-211-0/+3
* Fix compile error without SSL/TLS enabledTatsuhiro Tsujikawa2015-02-011-0/+2
* Add --min-tls-version optionTatsuhiro Tsujikawa2014-12-061-0/+6
* util::parseIntSegments: Return SegList<int>Tatsuhiro Tsujikawa2014-06-041-1/+1
* Support PREF_DIR change for Metalink filesTatsuhiro Tsujikawa2014-06-041-0/+2
* Internally use HMAC in http authNils Maier2014-05-221-5/+11
* Remove nativeToUtf8 and utf8ToNativeTatsuhiro Tsujikawa2013-11-011-4/+0
* Include prefs.h instead of typedef PrefPtr everywhereTatsuhiro Tsujikawa2013-09-261-2/+1
* Introduce PrefPtr typedefNils Maier2013-09-191-2/+3
* Fix util::nextParam when compiled with recent Apple clangNils Maier2013-08-201-2/+2
* Define a type for signal handlersNils Maier2013-08-181-2/+3
* Rewrite util::divideTatsuhiro Tsujikawa2013-06-251-11/+6
* toUpper, toLower: Let compiler copy srcTatsuhiro Tsujikawa2013-06-241-2/+2
* Require -std=c++11 and use std::shared_ptr instead of SharedHandleTatsuhiro Tsujikawa2013-06-221-6/+6
* uitos: Fix off-by-one error bugTatsuhiro Tsujikawa2013-04-291-1/+1
* Set sa_mask when setting signal handlerTatsuhiro Tsujikawa2013-02-141-1/+6
* Rewritten util::uitos()Tatsuhiro Tsujikawa2013-01-161-16/+19
* Made return type of util::parse_content_disposition ssize_tTatsuhiro Tsujikawa2012-11-011-3/+3
* Content-Disposition parser conforming to RFC 6266.Tatsuhiro Tsujikawa2012-10-271-1/+30
* Removed unused functionsTatsuhiro Tsujikawa2012-09-271-16/+0
* Use nothrow version of parseInt, parseUInt and parseLLIntTatsuhiro Tsujikawa2012-09-271-3/+0
* Made DEFAULT_STRIP_CHARSET const char[]Tatsuhiro Tsujikawa2012-09-241-13/+9
* Store only interesting HTTP headers in HttpHeaderTatsuhiro Tsujikawa2012-09-231-0/+3
* Rewritten DownloadHandlerConstantsTatsuhiro Tsujikawa2012-09-221-3/+3
* Use int64_t instead of off_tTatsuhiro Tsujikawa2012-06-251-1/+1
* Rewritten HTTP header parserTatsuhiro Tsujikawa2012-06-231-0/+4
* Don't use locale dependent toupper and tolower.Tatsuhiro Tsujikawa2012-03-311-0/+4
* Rewritten TLS hostname check based on RFC 6125.Tatsuhiro Tsujikawa2012-03-301-16/+1
* Added hostname check described in RFC 2818 with OpenSSL.Tatsuhiro Tsujikawa2012-03-281-0/+18
* Fixed clang warning and errors.Tatsuhiro Tsujikawa2012-03-011-47/+47
* Check scheme part in redirected URI more strictly.Tatsuhiro Tsujikawa2012-02-151-0/+2
* Avoid strlen in util::streq, util::strieq, util::startsWith and util::istarts...Tatsuhiro Tsujikawa2012-01-111-4/+26
* Use short form of util::startsWith and util::endsWithTatsuhiro Tsujikawa2012-01-111-0/+1
* Removed static const char[] as much as possible.Tatsuhiro Tsujikawa2012-01-111-7/+41
* Fixed compile error on android (which does not LFS support)Tatsuhiro Tsujikawa2011-12-261-1/+1
* Use int instead of unsigned int where unsigned int is not needed.Tatsuhiro Tsujikawa2011-12-091-1/+1
* Replaced uint64_t with off_t or int64_t.Tatsuhiro Tsujikawa2011-12-091-5/+1
* Don't append character to std::string.Tatsuhiro Tsujikawa2011-11-121-1/+1
* Rewritten parse*IntTatsuhiro Tsujikawa2011-11-121-165/+10