index
:
aria2
HEAD
diskspace
dynamic-select-file
libaria2
random-webseeding
rearrange-args
refactor-wintls-write
release-1.26.x
release-1.33.x
utp-support
Aria2 download utility with uTP support
Nagi
summary
refs
log
tree
commit
diff
log msg
author
committer
range
path:
root
/
src
/
util.h
Commit message (
Expand
)
Author
Age
Files
Lines
*
Enable IndentPPDirectives
Tatsuhiro Tsujikawa
2018-06-09
1
-4
/
+4
*
new option content-disposition-default-utf8
JimmyZ
2016-12-31
1
-2
/
+6
*
Allow subsecond value in ns cookie.txt file's expiry time field
Tatsuhiro Tsujikawa
2016-05-15
1
-0
/
+4
*
mingw: Defer the falloc warning until falloc is specified by option
Tatsuhiro Tsujikawa
2016-04-18
1
-0
/
+4
*
Don't inherit file descriptor to child process
Tatsuhiro Tsujikawa
2016-02-08
1
-0
/
+5
*
mingw: Add formatLastError as wrapper function for FormatMessage
Tatsuhiro Tsujikawa
2016-01-28
1
-0
/
+7
*
Refactor HttpRequest
Tatsuhiro Tsujikawa
2016-01-10
1
-0
/
+1
*
Refactor SocketCore::getPeerInfo, getAddrInfo to return Endpoint object
Tatsuhiro Tsujikawa
2016-01-09
1
-2
/
+1
*
make clang-format using clang-format-3.6
Tatsuhiro Tsujikawa
2015-12-27
1
-233
/
+198
*
Remove unused macros defined in util.h
Tatsuhiro Tsujikawa
2015-06-21
1
-8
/
+0
*
Use std::make_shared
Tatsuhiro Tsujikawa
2015-06-11
1
-1
/
+1
*
Make config and cache files conform to XDG
Vasilij Schneidermann
2015-06-02
1
-0
/
+7
*
Mingw: Use _wgetenv to get user's home directory
Tatsuhiro Tsujikawa
2015-02-21
1
-0
/
+3
*
Fix compile error without SSL/TLS enabled
Tatsuhiro Tsujikawa
2015-02-01
1
-0
/
+2
*
Add --min-tls-version option
Tatsuhiro Tsujikawa
2014-12-06
1
-0
/
+6
*
util::parseIntSegments: Return SegList<int>
Tatsuhiro Tsujikawa
2014-06-04
1
-1
/
+1
*
Support PREF_DIR change for Metalink files
Tatsuhiro Tsujikawa
2014-06-04
1
-0
/
+2
*
Internally use HMAC in http auth
Nils Maier
2014-05-22
1
-5
/
+11
*
Remove nativeToUtf8 and utf8ToNative
Tatsuhiro Tsujikawa
2013-11-01
1
-4
/
+0
*
Include prefs.h instead of typedef PrefPtr everywhere
Tatsuhiro Tsujikawa
2013-09-26
1
-2
/
+1
*
Introduce PrefPtr typedef
Nils Maier
2013-09-19
1
-2
/
+3
*
Fix util::nextParam when compiled with recent Apple clang
Nils Maier
2013-08-20
1
-2
/
+2
*
Define a type for signal handlers
Nils Maier
2013-08-18
1
-2
/
+3
*
Rewrite util::divide
Tatsuhiro Tsujikawa
2013-06-25
1
-11
/
+6
*
toUpper, toLower: Let compiler copy src
Tatsuhiro Tsujikawa
2013-06-24
1
-2
/
+2
*
Require -std=c++11 and use std::shared_ptr instead of SharedHandle
Tatsuhiro Tsujikawa
2013-06-22
1
-6
/
+6
*
uitos: Fix off-by-one error bug
Tatsuhiro Tsujikawa
2013-04-29
1
-1
/
+1
*
Set sa_mask when setting signal handler
Tatsuhiro Tsujikawa
2013-02-14
1
-1
/
+6
*
Rewritten util::uitos()
Tatsuhiro Tsujikawa
2013-01-16
1
-16
/
+19
*
Made return type of util::parse_content_disposition ssize_t
Tatsuhiro Tsujikawa
2012-11-01
1
-3
/
+3
*
Content-Disposition parser conforming to RFC 6266.
Tatsuhiro Tsujikawa
2012-10-27
1
-1
/
+30
*
Removed unused functions
Tatsuhiro Tsujikawa
2012-09-27
1
-16
/
+0
*
Use nothrow version of parseInt, parseUInt and parseLLInt
Tatsuhiro Tsujikawa
2012-09-27
1
-3
/
+0
*
Made DEFAULT_STRIP_CHARSET const char[]
Tatsuhiro Tsujikawa
2012-09-24
1
-13
/
+9
*
Store only interesting HTTP headers in HttpHeader
Tatsuhiro Tsujikawa
2012-09-23
1
-0
/
+3
*
Rewritten DownloadHandlerConstants
Tatsuhiro Tsujikawa
2012-09-22
1
-3
/
+3
*
Use int64_t instead of off_t
Tatsuhiro Tsujikawa
2012-06-25
1
-1
/
+1
*
Rewritten HTTP header parser
Tatsuhiro Tsujikawa
2012-06-23
1
-0
/
+4
*
Don't use locale dependent toupper and tolower.
Tatsuhiro Tsujikawa
2012-03-31
1
-0
/
+4
*
Rewritten TLS hostname check based on RFC 6125.
Tatsuhiro Tsujikawa
2012-03-30
1
-16
/
+1
*
Added hostname check described in RFC 2818 with OpenSSL.
Tatsuhiro Tsujikawa
2012-03-28
1
-0
/
+18
*
Fixed clang warning and errors.
Tatsuhiro Tsujikawa
2012-03-01
1
-47
/
+47
*
Check scheme part in redirected URI more strictly.
Tatsuhiro Tsujikawa
2012-02-15
1
-0
/
+2
*
Avoid strlen in util::streq, util::strieq, util::startsWith and util::istarts...
Tatsuhiro Tsujikawa
2012-01-11
1
-4
/
+26
*
Use short form of util::startsWith and util::endsWith
Tatsuhiro Tsujikawa
2012-01-11
1
-0
/
+1
*
Removed static const char[] as much as possible.
Tatsuhiro Tsujikawa
2012-01-11
1
-7
/
+41
*
Fixed compile error on android (which does not LFS support)
Tatsuhiro Tsujikawa
2011-12-26
1
-1
/
+1
*
Use int instead of unsigned int where unsigned int is not needed.
Tatsuhiro Tsujikawa
2011-12-09
1
-1
/
+1
*
Replaced uint64_t with off_t or int64_t.
Tatsuhiro Tsujikawa
2011-12-09
1
-5
/
+1
*
Don't append character to std::string.
Tatsuhiro Tsujikawa
2011-11-12
1
-1
/
+1
[next]