summaryrefslogtreecommitdiff
path: root/src/util.cc
Commit message (Expand)AuthorAgeFilesLines
* util.cc: Include only signal.h for opensolaris buildTatsuhiro Tsujikawa2013-03-171-0/+7
* Check for sys/signal.h and/or signal.hNils Maier2013-03-021-1/+8
* Fix bustage on OSX with ./configure CC=cc CXX=c++ (clang)Nils Maier2013-03-011-1/+1
* Set sa_mask when setting signal handlerTatsuhiro Tsujikawa2013-02-141-2/+3
* Use _exit() instead of exit() where appropriateTatsuhiro Tsujikawa2013-02-141-1/+1
* Accept k and m as well as K and M in util::getRealSize()Tatsuhiro Tsujikawa2013-01-151-3/+8
* Changed threshold of using upper unit for abbrevSizeTatsuhiro Tsujikawa2012-12-191-1/+1
* Use 64 bits random bytes as GIDTatsuhiro Tsujikawa2012-12-161-1/+1
* Compact readout when more than 1 simultaneous downloads are going onTatsuhiro Tsujikawa2012-12-111-14/+23
* Removed unused static function util::parseParamTatsuhiro Tsujikawa2012-11-171-41/+0
* Made return type of util::parse_content_disposition ssize_tTatsuhiro Tsujikawa2012-11-011-5/+6
* Use len formal parameter of util::parse_content_dispositionTatsuhiro Tsujikawa2012-10-311-2/+2
* Removed always-true conditionTatsuhiro Tsujikawa2012-10-291-1/+1
* Content-Disposition parser conforming to RFC 6266.Tatsuhiro Tsujikawa2012-10-271-91/+414
* Removed trailing spacesTatsuhiro Tsujikawa2012-10-011-4/+4
* Removed *Handle typedefTatsuhiro Tsujikawa2012-09-281-1/+1
* Removed unused functionsTatsuhiro Tsujikawa2012-09-271-62/+2
* Use nothrow version of parseInt, parseUInt and parseLLIntTatsuhiro Tsujikawa2012-09-271-49/+23
* Code cleanupTatsuhiro Tsujikawa2012-09-261-2/+1
* Made BufferedFile ctor take const char* argsTatsuhiro Tsujikawa2012-09-251-1/+1
* Made DEFAULT_STRIP_CHARSET const char[]Tatsuhiro Tsujikawa2012-09-241-4/+3
* Removed A2STR strings other than NILTatsuhiro Tsujikawa2012-09-241-1/+1
* Store only interesting HTTP headers in HttpHeaderTatsuhiro Tsujikawa2012-09-231-0/+5
* Rewritten DownloadHandlerConstantsTatsuhiro Tsujikawa2012-09-221-15/+10
* Use execlp() instead of execl()Tatsuhiro Tsujikawa2012-09-071-6/+6
* Don't percent-decode filename value in Content-Disposition.Tatsuhiro Tsujikawa2012-06-281-2/+3
* Use int64_t instead of off_tTatsuhiro Tsujikawa2012-06-251-4/+4
* Use PRId64 for int64_t format specifierTatsuhiro Tsujikawa2012-06-251-1/+1
* Rewritten HTTP header parserTatsuhiro Tsujikawa2012-06-231-0/+9
* Use CreateProcessW instead of CreateProcessATatsuhiro Tsujikawa2012-04-071-12/+16
* Fixed compile error with i686-w64-mingw32Tatsuhiro Tsujikawa2012-04-071-5/+5
* Check availability of pwd.hTatsuhiro Tsujikawa2012-04-071-3/+5
* First check there is wildcard character or not in tls hostname check.Tatsuhiro Tsujikawa2012-04-011-16/+14
* Don't use locale dependent toupper and tolower.Tatsuhiro Tsujikawa2012-03-311-4/+20
* Rewritten TLS hostname check based on RFC 6125.Tatsuhiro Tsujikawa2012-03-301-29/+39
* Get the home directory of the effective user ID using getpwuid() ifTatsuhiro Tsujikawa2012-03-301-1/+8
* Added hostname check described in RFC 2818 with OpenSSL.Tatsuhiro Tsujikawa2012-03-281-0/+37
* Avoid strlen in util::streq, util::strieq, util::startsWith and util::istarts...Tatsuhiro Tsujikawa2012-01-111-2/+2
* Use short form of util::startsWith and util::endsWithTatsuhiro Tsujikawa2012-01-111-0/+5
* Removed static const char[] as much as possible.Tatsuhiro Tsujikawa2012-01-111-56/+52
* Use std::ifstream instead of file descriptor for generateRandomDataUrandom()Tatsuhiro Tsujikawa2012-01-081-18/+10
* Fixed compile error on android (which does not LFS support)Tatsuhiro Tsujikawa2011-12-261-3/+3
* Replaced uint64_t with off_t or int64_t.Tatsuhiro Tsujikawa2011-12-091-31/+5
* Fixed bug in util::parseULLIntNoThrow()Tatsuhiro Tsujikawa2011-12-021-1/+1
* Return true if bits == 0 in util::inSameCidrBlock()Tatsuhiro Tsujikawa2011-12-021-0/+3
* Changed format of ETA.Tatsuhiro Tsujikawa2011-11-131-12/+5
* Use fmt instead of util::itosTatsuhiro Tsujikawa2011-11-131-7/+3
* Don't append character to std::string.Tatsuhiro Tsujikawa2011-11-121-6/+4
* Removed strappendTatsuhiro Tsujikawa2011-11-121-2/+10
* Removed strconcatTatsuhiro Tsujikawa2011-11-121-4/+9