| Commit message (Collapse) | Author | Age | Files | Lines |
| ... | |
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
30 March 2022: babeld-1.11
* Implemented MAC authentication (RFC 8967). Thanks to Clara Dô,
Weronika Kołodziejak and Antonin Décimo.
* Changed the interface of the add_filter function in order to simplify
integration in OpenWRT. Thanks to Nick Hainke.
Detailed List:
7c053fe Export add_filters and simplify interface.
91c44f8 Rename blake2s to blake2s128.
dda8d63 Update CHANGES.
43a0066 Allow Blake2s keys up to 32 bytes.
375ea5f Rename interface option hmac to key.
1b9abc4 Replace hmac-verify with accept-bad-signatures.
3777eb4 Ignore .gitmodules when releasing an archive.
3551b45 Simplify and fix preparse phase.
ba8f116 Add rate limitations for challenges.
6d44238 Show PC number.
ceda3a0 Expire Index and challenge timer.
d66a4d2 Ignore a Challenge Request received on multicast.
024c17a Fix confusion between INDEX_LEN and NONCE_LEN when sending PC TLV.
ceb021f Fix double-free in error path.
1e08aed Change no_hmac_verify to hmac-verify.
c7ad387 Use 'hmac-sha256' and not 'sha256'.
5a15957 Fix nodes incorrectly rejecting packets.
af02039 Append a PC message if Babel-MAC is enabled.
46fc7da Follow the spec closely for the preparse phase.
87f39d0 Rename MAC functions and constants to match the spec.
02b14e3 Helpful error messages in key configuration.
d763f3e Error if configured key can't be found.
3cb0ab7 Use RFC3542 for IPv6 on macOS.
69df1cb Use _GNU_SOURCE instead of __USE_GNU.
ef3a113 Don't copy nonce, suppress VLA.
c243769 Move key validation in parse_key.
b06b2fc Constify source argument of fromhex.
9529941 Use AUTH_TYPE_NONE consistently.
d922b64 Document the HMAC options in manual page.
0c4afc2 Only allow keys configured on a given interface.
7de6715 Create neighbour after checking HMAC.
ecd1f42 Fix typo in compare_hmac.
9a5de34 Fix HMAC-SHA-256 computation.
f1051fd Fix constants to be consistent with SHA-256.
9688b68 Fix memory leaks in error-handling paths in configuration parser.
4d8a831 Fix some more (read-only) buffer overflows.
ebda926 Fix potential memory leaks.
d53fec0 Use AUTH_TYPE_* consistently.
a1afd51 Add no_hmac_verify flag.
b4e28f2 Fix ordering of fields in pseudo-header.
c8ace8b Use IANA-assigned TLV numbers.
739f76a Implement HMAC authentication.
e3adf47 Compile with SHA-256 and Blake2s.
ca0a512 Add SHA-2 and Blake2 submodules.
756783e Untabify
Remove upstreamed patches:
- 000-export-add-filters-and-simplify-interface.patch
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit dbff012a2ff5b8a75f3f5e9d3ccd72ee5c91b575)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
In order to use feeds from GH mirror for GH actions, thus saving a lot
of resources being wasted. While at it fix whitespace issue.
Signed-off-by: Petr Štetiar <ynezz@true.cz>
[applied to routing feed]
[whitespace issue not existing in routing feed]
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 5702d2e40bff2fa45b4f628c4c7a9acdcf6d1e31)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| | |
No also check mirror hashes and badly formated init files
Signed-off-by: Paul Spooren <mail@aparcar.org>
[applied to routing feed]
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 2134c56d12ced1c5b191b35e18f8330384860f15)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
You can define filter functions in babeld by:
in if eth0 metric 128
This commit adds the ubus equivalent to dynamically add filter on
runtime:
ubus call babeld add_filter '{"ifname":"eth0", "type":"input",
"metric":128}'
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit a618159d33e02e9a295388e605447993eca11e52)
|
| | |
| |
| |
| |
| |
| |
| |
| | |
You can now give a lqm when adding an interface:
ubus call olsrd add_interface '{"ifname":"wg_51821", "lqm":"0.5"}'
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit e3c68429239f77c895b32502e2609df8b72c6caa)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Maintainer: Rob White rob@blue-wave.net
Compile tested: arm_cortex-a7_neon-vfpv4, mipsel_24kc
Run tested: arm_cortex-a7_neon-vfpv4, mipsel_24kc, x86-64, on 21.02.2
* This version adds new functionality, and fixes some issues
* Fix - syntax error (missing comma) in awk command in bash on generic Linux [bluewavenet]
* Add - option to append serial number suffix to gatewayname [bluewavenet]
* Add - block use of ip aliases on gateway interface [doctor-ox] [bluewavenet]
* Fix - ndsctl json syntax error [bluewavenet]
* Add - check for null variables in key value pairs in MHD callbacks [bluewavenet]
* Fix - changed some notice messages into debug messages [bluewavenet]
* Fix - possible return of incorrect pid [doctor-ox] [bluewavenet]
* Fix - possible abiguities resulting in failure to parse parameters correctly [bluewavenet]
* Fix - Remove deprecated get_client_token.sh [bluewavenet]
* Fix - Prevent possible malformed mac address returned from dhcpcheck() [doctor-ox] [bluewavenet]
Signed-off-by: Rob White <rob@blue-wave.net>
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Compile time changes reviewed by cjd.
Due to stricter compiler(s) we do not
want to error for these warnings.
Caused by: ...reading "past the end"
of a struct, because the struct is
actually a header and the body is of
unknown size. Compilers got stricter
and this became a warning.
Signed-off-by: William Fleurant <meshnet@protonmail.com>
(cherry picked from commit 71c11ab1b7d7f6ca3219c1359e20b168ec1979c5)
[Fix compiling]
Signed-off-by: Nick Hainke <vincent@systemli.org>
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Since https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=4b9a67362d70c544b85078b8d5c661f43f7472d9,
uci network config interface sections use 'device' instead of 'ifname'
Even if 'device' seems to always be set by
package/base-files/files/bin/config_generate, we keep the fallbacks
in case someone install the package via opkg and has a non migrated
network config
Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
(cherry picked from commit 383c52ff8d9c0577a262d014aca66bd4095f4e38)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
- Switch to AUTORELEASE
- Changed package versioning:
Before: mrd6_2013-11-30-c805eb33255dbc0b6647d463c6c67d1c9d3105a0-3_arm_cortex-a9_vfpv3-d16.ipk
After: mrd6_2013-11-30-c805eb33-1_arm_cortex-a9_vfpv3-d16.ipk
- Remove defaults, which are already defaults
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
(cherry picked from commit e06a6c962b3e44f29b38369a7dbfda0bfcaa6dc6)
|
| | |
| |
| |
| |
| |
| |
| |
| | |
This avoids unnecessary downloads and rebuilds.
Patches were refreshed to please github PR checks.
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit 564ca99e2c3bd044fb195c4311bca094680d9aa1)
|
| | |
| |
| |
| |
| |
| |
| | |
This avoids unnecessary downloads and rebuilds.
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit ade1fa6ebc0d3cb409849e03ab17825ca7fdb345)
|
| | |
| |
| |
| |
| |
| |
| | |
This avoids unnecessary downloads and rebuilds.
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit e9d5f990a3994d9064a4b5e339b24abe735b1eca)
|
| | |
| |
| |
| |
| |
| |
| | |
This avoids unnecessary downloads and rebuilds.
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit 9cb03f0a2f6f1f84672f1d88385fa2244a423e53)
|
| | |
| |
| |
| |
| |
| |
| |
| | |
- Why there was oonf-git? WTF?
- Use two spaces instead of tabs
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
(cherry picked from commit 282af3f8bce72dc976ec28b9d05dbc1e665489ee)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
- By this change, we are using downloading .tar.xz (which is default in OpenWrt)
Reference: OpenWrt base repository include/download.mk
Downloaded tarball size is ~60 kB smaller.
- Removed "v" in package naming.
Before: oonf-dlep-radio_v0.15.1_arm_cortex-a9_vfpv3-d16.ipk
After: oonf-dlep-radio_0.15.1_arm_cortex-a9_vfpv3-d16.ipk
Removed stuff, which is no longer needed like PKG_REV.
- Switch to AUTORELEASE in PKG_RELEASE
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
(cherry picked from commit 56fc0d7226116a5e18b9d1686d71e136465b7dc5)
|
| | |
| |
| |
| |
| | |
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 24b27f0875e92759d95e394a39aa2c0be2d3176a)
|
| | |
| |
| |
| |
| | |
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit c762d3fd0f73a5db6357d62f24570a98be540273)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Fixes:
oonf-dlep-radio-v0.15.1.tar.bz2: Download from https://github.com/OLSR/OONF.git failed
oonf-dlep-radio-v0.15.1.tar.bz2: Requires sha256sum for verification
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 9a90e3dd658577022fb3484050835907920ee0f0)
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
[added commit message]
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Maintainer: Rob White rob@blue-wave.net
Compile tested: arm_cortex-a7_neon-vfpv4, mipsel_24kc
Run tested: arm_cortex-a7_neon-vfpv4, mipsel_24kc, gl-inet b1300, gl-inet mt300n-v2, Snapshot, 21.02.1, 19.07.8
Description:
This version adds new functionality, and fixes some issues
It requires iptables(legacy)
* Fix - correctly display return buffer in syslog [bluewavenet]
* Add - use heap allocation for library call return buffer [bluewavenet]
* Fix - OpenWrt, fhook request for fw3 [bluewavenet]
* Add - spider remote urls before downloading [bluewavenet]
* Add - OpenWrt, revert uncommitted uci updates at startup and shutdown [bluewavenet]
* Fix - remove unneccesary flash writes and fix hosts updates [doctor-ox] [bluewavenet]
* Add - Updated splash images [bluewavenet]
* Add - OpenWrt makefile for nft or ipt dependencies [bluewavenet]
* Fix - grep by word to prevent any ambiguity [doctor-ox] [bluewavenet]
* Fix - ensure rate limiting is disabled if rate thresholds are set to zero [bluewavenet]
* Add - querystring support for client status page [bluewavenet]
* Add - Advanced/standard status page checkbox [bluewavenet]
* Add - set default session timeout to 24 hours [bluewavenet]
* Fix - potential buffer overflow [bluewavenet]
* Fix - Restrict max packet limit to iptables maximum [bluewavenet]
* Fix - descriptive labels on ndsctl status output [bluewavenet]
* Add - update of README.md [bluewavenet]
* Fix - Added required variable to FAS return string example documentation [dorkone]
* Add - Default checkinterval set to 15 seconds [bluewavenet]
* Fix - incoming and outgoing counters when unlimited bursting is enabled [bluewavenet]
* Add - maximum bucket size configuration [bluewavenet]
* Add - calculate moving average packet size for rate limiting [bluewavenet]
* Add - some operational default values [bluewavenet]
* Add - initial rate limits when unrestricted bursting is disabled [bluewavenet]
* Add - Require clients to be in the dhcp database [bluewavenet]
* Add - dhcpcheck library call [bluewavenet]
* Fix - Remove trailing whitespace when getting clientaddress if client not active [bluewavenet]
* Fix - Segfault when FAS fails to Return customstring [dorkone] [bluewavenet]
* Add - Enable/Disable unrestricted bursting [bluewavenet]
* Add - gatewayurl to querystring and use in place of originurl in FAS [bluewavenet]
* Fix - more accurate debug message [bluewavenet]
* Fix - Show packet rate correctly as packets per minute [bluewavenet]
* Add - Report Packet Rate and Bucket Size in ndsctl status and json and status client page [bluewavenet]
* Add - rate limit refresh to client limit rules [bluewavenet]
* Fix - code readability [bluewavenet]
* Fix - Documentation for data sent to Authmon Daemon [bluewavenet]
* Add - Show unrestricted burst intervals in ndsctl status [bluewavenet]
* Add - Set default bucket ratios to 10 [bluewavenet]
Signed-off-by: Rob White <rob@blue-wave.net>
|
| | |
| |
| |
| |
| |
| |
| | |
The IPC should apply the "InterfaceDefaults".
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 4afbe1748020e1677ec5529198d92e1870d3c012)
|
| |\|
| |
| | |
openwrt-21.02: batman-adv: Merge bugfixes from 2022.0
|
| | |
| |
| |
| |
| |
| |
| | |
* allow netlink usage in unprivileged containers
* mcast: don't send link-local multicast to mcast routers
Signed-off-by: Sven Eckelmann <sven@narfation.org>
|
| | |
| |
| |
| |
| |
| |
| |
| |
| | |
There is an unused variable in the function. Remove it.
Fixes: 385200443554 ("babeld: add add_interface function").
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 879725ce3e2e6e48bbcfed7380ecf3f59cb58edd)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
An interface can be added dynmiacally to babeld by starting babeld with
the local management interface (-G) and saying:
interface eth0
Add the ubus equivalent of this function:
ubus call babeld add_interface '{"ifname":"eth0"}'
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 385200443554ab87e0205f5551f7a0c1883da776)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
IPC integration of olsrd with OpenWrt. Allow dynamic adding and removing
of interfaces at run-time. We need to rename the avl-tree files, since
libubox also defines avl tree. Also add patch to allow meshing via
wireguard point-to-point links.
The ubus interface offers following functions:
- add_inteface '{"ifname":"wg_51820"}'
- del_inteface '{"ifname":"wg_51820"}'
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 0bffe620b441c039780d4336a15c8ed4f2ebbbf4)
|
| | |
| |
| |
| |
| |
| |
| |
| | |
The runtime testing always ran on master branch aka snapshots since the
branch wasn't passed over to the container execution!
Signed-off-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit 817240b07c7158c72de427051eb9bae1c39b3abe)
|
| | |
| |
| |
| |
| |
| |
| |
| | |
Check multiple rounds if neighbors are available before kicking. This
should reduce unneeded reboots.
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 24285ce4fcd56aa806bdbe9ac16cbfed0a81d2f8)
|
| | |
| |
| |
| |
| |
| |
| | |
The if-condition was always evaluated to be true.
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit cf34c5a4a1ace3f8eeac2d2b9b8539e085e8fabf)
|
| | |
| |
| |
| |
| |
| |
| |
| | |
The procd script was not adding the wireguard interfaces. Add corner case
in the init script to allow meshing via wireguard.
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 576967a2a3eaa468bcba2f24708ea4674b7e3586)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Maintainer: Rob White rob@blue-wave.net
Compile tested: arm_cortex-a7_neon-vfpv4, mipsel_24kc
Run tested: arm_cortex-a7_neon-vfpv4, mipsel_24kc, gl-inet b1300, gl-inet mt300n-v2, Snapshot, 21.02.1, 19.07.8
Description:
This version adds new functionality, and fixes some issues
* Fix - ThemeSpec file downloads when mwan3 is running [bluewavenet]
* Fix - Preemptive auth failure after previous deauth [minhng99] [bluewavenet]
From v9.5.0
* Add - use average packet size instead of MTU when implementing rate limiting [bluewavenet]
* Fix - typo in iptables command and remove a redundant command [bluewavenet]
* Add - startdaemon() and stopdaemon() utility functions [bluewavenet]
* Add - combined interface/ipaddress external gateway status monitoring [bluewavenet]
* Fix - potential online/offline detection problem when mwan3 is running [bluewavenet]
* Add - get_debug_level and syslog library calls [bluewavenet]
* Fix - correctly reset upload and download rate rules [bluewavenet]
* Add - extend upstream gateway checking for use with mwan3 loadbalance/failover [bluewavenet]
* Fix - Potential NULL pointer segfault in http_microhttpd on calling authenticated() [bluewavenet]
* Fix - Potential NULL pointer segfault in http_microhttpd on calling preauthenticated() [dddaniel]
* Add - Calculate Bucket size based on achieved burst rate [bluewavenet]
* Fix - prevent parameter parsing if clientip not known [bluewavenet]
* Add - disable rate quotas by setting bucket ratio to zero [bluewavenet]
* Fix - suppress some debug messages [bluewavenet]
* Add - more libraries documentation [bluewavenet]
* Add - library calls startdaemon and stopdaemon [bluewavenet]
* Fix - Increase buffer length for longer interface names [koivunen]
* Add - Update README.md [bluewavenet]
* Add - bucket ratio option to config file [bluewavenet]
* Add - upload and download bucket ratio config values [bluewavenet]
* Fix - flag initial debuglevel to externals [bluewavenet]
* Add - limit-burst tuning to rate quotas [bluewavenet]
* Fix - add trailing space to defaultip [bluewavenet]
* Add - record pre-emptive authentication in local log [bluewavenet]
* Add - Write to local log function to libopennds [bluewavenet]
* Add - set client_type and custom string for Pre-emptive authentication [bluewavenet]
* Fix - Remove trailing newline from library call response [bluewavenet]
* Fix - attempt to remove cid file only if client->cid is set [bluewavenet]
* Add - a skip option for custom downloads to speed up serving page from themespec [bluewavenet]
* Add - put client_type into query string when type is cpd canary [bluewavenet]
* Add - set refresh=0 before loading images [bluewavenet]
* Fix - Truncated return status [bluewavenet]
* Add - Acknowlegement from call to dnsconfig [bluewavenet]
* Fix - potential buffer overflow in debug output [bluewavenet]
* Add - processing of custom data and client type [bluewavenet]
* Add - Client Type for RFC8908 and RFC8910 clients [bluewavenet]
* Add - rfc8908 replies for external FAS and refactor memory management for MHD calls [bluewavenet]
* Add - send error 403 if client is not on openNDS subnet [bluewavenet]
* Fix - remove uneccessary safe_asprint in auth.c [bluewavenet]
* Fix - Initialise buffer to prevent receiving spurious characters [bluewavenet]
* Add - encoded custom data support to ndsctl json, themespec and binauth [bluewavenet]
* Add - advert_1.htm to thankyou page of theme_click-to-continue-custom-placeholders.sh [bluewavenet]
* Add - library call get_interface_by_ip [bluewavenet]
* Add - function encode_custom() for encoding custom data to be sent to openNDS [bluewavenet]
* Fix - error 511, make all html refrences absolute to enforce link to MHD [bluewavenet]
* Add - check status_path exists and is executeable [bluewavenet]
* Fix - regression causing error 511 to be served from default script [bluewavenet]
* Add - venue-info-url and can-extend-session json keys [bluewavenet]
* Add - RFC 8908 initial experimental support [bluewavenet]
* Add - debug message when resetting client [bluewavenet]
* Fix - Ensure the ndscids directory exists before trying to write to it. [bluewavenet]
* Fix - use eval in do_ndsctl to allow quoting of arguments [bluewavenet]
* Fix - ensure client hid and client cid file is reset correctly [bluewavenet]
* Fix - Titles of example ThemeSpec Files [bluewavenet]
* Fix - Ensure ThemeSpec Files are executable [bluewavenet]
* Remove - deprecated Allowed and Blocked entries in ndsctl status output [bluewavenet]
* Add - Deprecate option macmechanism, allowedmaclist and blockedmaclist [bluewavenet]
Signed-off-by: Rob White <rob@blue-wave.net>
|
| | |
| |
| |
| |
| |
| |
| | |
Change log level from debug to info to avoid filling up syslog with query-level logging.
Signed-off-by: Maarten Aertsen <spam-github@rtsn.nl>
(cherry picked from commit 4f235865e7d8c37b4ea7d8ee55b4e603a11e06b7)
|
| |\|
| |
| | |
openwrt-21.02: batman-adv: Prevent use from libc headers to not build with BIG_ENDIAN
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Commit 97d35a552ec5b6ddf7923dd2f9a8eb973526acea of musl introduced the
macros __LITTLE_ENDIAN and __BIG_ENDIAN in alltypes.h. These are pulled
into the compilation of batman-adv. This has the side effect that the
function is_multicast_ether_addr of etherdevice.h in Linux kernel is
compiled as the big endian version and so fails to work properly on
little endian devices.
This commits prevents pulling in header files of musl libc similar to
OpenWRT commit 9ac47ee46918c45b91f4e4d1fa76b1e26b9d57fe
Signed-off-by: Hendrik Borghorst <hendrikborghorst@gmail.com>
(cherry picked from commit 523821c1959cb288b55b7fcc8761c83f6ff48c4d)
Signed-off-by: Sven Eckelmann <sven@narfation.org>
|
| |\|
| |
| | |
openwrt-21.02: batman-adv: Merge bugfixes from 2021.4
|
| | |
| |
| |
| |
| |
| | |
* fix error handling during interface initialization
Signed-off-by: Sven Eckelmann <sven@narfation.org>
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Naywatch in combination with the watchdog can be tricky and dangerous
when doing a sysupgrade. Add a warning to always stop naywatch first and
check if procd took control over the watchdog again.
Also change use_watchdog to '0'.
Signed-off-by: Nick Hainke <vincent@systemli.org>
|
| | |
| |
| |
| |
| |
| |
| |
| |
| | |
For some reason the buffer is initialized twice before filling it.
This does not break anything but is useless. Reduce the initialization
to only one.
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 2cf253b3df2db7830692de645504db294151e5ab)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
As Felix mentioned:
If a buffer was already allocated, blob_buf_init reuses it. You can
keep reusing it as many times as you want. You only need to call
blob_buf_free if you explicitly want to free the buffer memory
(e.g. on exit, or if the blob_buf is on stack).
http://lists.openwrt.org/pipermail/openwrt-devel/2021-October/036722.html
This PR frees the blob-buffers that are on the stack.
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 6d463ca97cf329fe5b7bb29ff5581076ff7245f9)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Wait for wireless to initialize (pending="false") to ensure
that any olsrd(6) configured interfaces and their associated
devices are up. This provides the init script the ability
to properly add all interface sections to the generated
config file /tmp/etc/olsrd(6).conf
Signed-off-by: Perry Melange <isprotejesvalkata@gmail.com>
(cherry picked from commit 0bb6aa04f6ed27fcea341d21a09fd3bcab86cd89)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| | |
Sometimes, naywatch can not handover the watchdog to procd again using
ubus. We need to call the same ubus command multiple times until procd
takes over control again.
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit e35255710bda08f162a185be8c460b6a80e19fb1)
|
| | |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Maintainer: Rob White rob@blue-wave.net
Compile tested: arm_cortex-a7_neon-vfpv4, mipsel_24kc
Run tested: arm_cortex-a7_neon-vfpv4, mipsel_24kc, gl-inet b1300, gl-inet mt300n-v2, Snapshot, 21.02.0, 19.07.8
Description:
This version adds new functionality, and fixes some issues
* Add - Error message in fas-aes-https if shared key is mismatched [bluewave.net]
* Fix - and refactor error 511 page generation[bluewave.net]
* Fix - and refactor dnsmasq configuration [bluewave.net]
* Fix - Typographic error preventing RFC8910 disable [bluewave.net]
* Add - gateway address and gatewayfqdn to ndsctl json output [bluewave.net]
* Add - RFC8910 housekeeping on startup and shutdown [bluewave.net]
* Add - correctly apply dhcp option 114 for generic Linux [bluewave.net]
* Add - reading of configured ndsctlsocket in ndsctl utility[bluewave.net]
* Add - use send_error 200 for MHD watchdog [bluewave.net]
* Add - generation of page_511 html by library script [bluewave.net]
* Add - extend debuglevel support to library scripts [bluewave.net]
* Refactor - fas-aes-https to simplify and make customisation of http easier [bluewave.net]
* Add - library script for error 511 page, allowing customisation [bluewave.net]
* Add - make authmon report connection error details [bluewave.net]
* Fix- remove unwanted debug message in ndsctl [bluewave.net]
* Add - RFC8910 support by default [bluewave.net]
* Add - display status page when accessing /login when authenticated [bluewave.net]
* Add - MHD response to RFC8910 requests [bluewave.net]
* Add - Dnsmasq RFC8910 configuration [bluewave.net]
* Add - send error 511 in response to unsupported http method [bluewave.net]
* Add - Check for ca-bundle on OpenWrt, if not installed, add syslog messages and terminate [bluewave.net]
* Add - Make ndsctl use the configured value for socket path if set and deprecate -s option [bluewave.net]
* Add - Warning message when Walled Garden port 80 is allowed [bluewave.net]
* Fix - remove un-needed pthread_kill in termination_handler() [bluewave.net] [T-X]
* Fix - debug messages from authmon.sh [bluewave.net]
* Fix - Allow disabling gateway fqdn, facilitating access to router port 80 [bluewave.net]
* Fix - Segfault in ndsctl when -s option is used incorrectly [bluewave.net] [T-X]
* Fix - Typo making calculation of ul/dl rates incorrect [bluewave.net]
* Fix - Allow port 80 to be configured in the Walled Garden [bluewave.net]
Signed-off-by: Rob White <rob@blue-wave.net>
|
| |\|
| |
| | |
openwrt-21.02: batman-adv: Merge bugfixes from 2021.2
|
| | |
| |
| |
| |
| |
| |
| | |
The test builds are now requiring quilt refreshed patches instead of git
patches. Otherwise the build check will not even try to build something.
Signed-off-by: Sven Eckelmann <sven@narfation.org>
|
| |/
|
|
|
|
| |
* Avoid WARN_ON timing related checks
Signed-off-by: Sven Eckelmann <sven@narfation.org>
|
| |
|
|
|
|
|
|
|
|
|
|
| |
The plugin adds a possibility to filter out gateway HNAs. This can be
very handy e.g. for faulty nodes. A gateway can be taken out directly on
a central node and all traffic is then redirected. Also the underlying
smart gateways are adapted. Currently the link multiplier is often used
to control a faulty node, but it is not necessarily the best way to do
so.
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit bdec65a6d91025cb05ceea9ea962320bf26e5987)
|
| |
|
|
|
|
|
|
| |
- filtergw: add plugin allow to allow/block gateways
(even smartgateway)
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit a302ee626511d3786299acb6d24ba8b29f2d5fe6)
|
| |
|
|
|
|
|
| |
Use SPDX license headers to be machine readable.
Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit 1326a6c252a05f13f2eca5216fd1f30aa84439cd)
|
| |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
On a Netgear R7800, if ospf v2 or v3 is configured in bird.conf, it fails to start with this error:
Fri Jun 11 14:41:11 2021 daemon.info bird: Started
Fri Jun 11 14:41:11 2021 kern.err kernel: [ 3500.853248] Alignment trap: not handling instruction f44c0a1f at [<00035848>] Fri Jun 11 14:41:11 2021 kern.alert kernel: [ 3500.853283] 8<--- cut here ---
Fri Jun 11 14:41:11 2021 kern.alert kernel: [ 3500.859363] Unhandled fault: alignment exception (0x801) at 0x007e0624
Fri Jun 11 14:41:11 2021 kern.alert kernel: [ 3500.862443] pgd = 0bbef4fd
Fri Jun 11 14:41:11 2021 kern.alert kernel: [ 3500.868821] [007e0624] *pgd=5d6ca835, *pte=5c40b75f, *ppte=5c40bc7f
The problem is due to a struct not being properly aligned on the ARMv7 architecture.
This patch fixes the problem by adding the "PACKED" macro to the affected struct. Note
that upstream may later fix this in another way, in which case this patch will not be required.
Signed-off-by: Matt Reeve <matt@mreeve.com>
|
| |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Maintainer: Rob White rob@blue-wave.net
Compile tested: arm_cortex-a7_neon-vfpv4, mipsel_24kc
Run tested: arm_cortex-a7_neon-vfpv4, mipsel_24kc, gl-inet b1300, gl-inet mt300n-v2, Snapshot, 21.02.0-rc3, 19.07.7
Description:
This version adds new functionality, and fixes some issues
* Add - firewall passthrough mode for authenticated users [bluewave.net]
* Add - use configured debuglevel in authmon [bluewave.net]
* Add - automated log rotation and client_zone to binauth_log [bluewave.net]
* Add - increased timeout interval for file downloads [bluewave.net]
* Add - local interface to MeshZone and remove unneeded call to ip utility [bluewave.net]
* Add - log_mountpoint and max_log_entries options [bluewave.net]
* Add - config variables ext_interface and ext_gateway [bluewave.net]
* Add - Start initial download of remotes only if online [bluewave.net]
* Add - Router online/offline watchdog [bluewave.net]
* Fix - Segfault when gatewayfqdn is disabled [bluewave.net]
* Fix - missing clientmac when not using themespec [bluewave.net]
* Fix - some compiler warnings [bluewave.net]
* Fix - use configured value for webroot for remote image symlink to images folder [bluewave.net]
* Fix - remove refrences to login.sh in documentation and comments [bluewave.net]
* Fix - Prevent potential read overrun within the MHD page buffer [bluewave.net]
* Remove - legacy get_ext_iface() function [bluewave.net]
Signed-off-by: Rob White <rob@blue-wave.net>
|
| |
|
|
|
|
|
|
|
|
|
|
|
| |
The network may crash on the SoCs, but the SoC itself does not. This
leads to a node no longer being accessible in a mesh network. If the
node is placed in a location that is not easily accessible, e.g. in a
high tower, it can cause a lot of problems. Therefore we check the
link-local connectivity on the configured interfaces.
Signed-off-by: Nick Hainke <vincent@systemli.org>
Tested-by: Simon Polack <spolack+git@mailbox.org>
Signed-off-by: Simon Polack <spolack+git@mailbox.org>
(cherry picked from commit 1088e65440b1f2f67b40e6a3073571da14f6a4b3)
|