diff options
| author | Paul Donald <newtwen@gmail.com> | 2023-12-19 04:02:50 +0100 |
|---|---|---|
| committer | Paul Donald <newtwen@gmail.com> | 2023-12-19 04:06:08 +0100 |
| commit | 75a8e4d3c912a1489248da42e347b12ddb9f6f31 (patch) | |
| tree | 2cdf8ce328341fbb713ea38030b70a7cefb83950 | |
| parent | 04e4ecad26d8d0dd2e222261f9611ed916f68f0b (diff) | |
luci-mod-network: reword some help-strings
also unburden translators from some static strings.
Signed-off-by: Paul Donald <newtwen@gmail.com>
(cherry picked from commit 0a67f0b880a01a687b4c53935656ccb755adafe6)
37 files changed, 79 insertions, 72 deletions
diff --git a/modules/luci-base/po/ar/base.po b/modules/luci-base/po/ar/base.po index b126850c4b..dcb45a0a7b 100644 --- a/modules/luci-base/po/ar/base.po +++ b/modules/luci-base/po/ar/base.po @@ -2439,8 +2439,8 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." -msgstr "تجاهل استجابات المنبع RFC1918" +"Discard upstream responses containing {rfc_1918_link} addresses." +msgstr "تجاهل استجابات المنبع {rfc_1918_link}" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/bg/base.po b/modules/luci-base/po/bg/base.po index e08b899671..1d86596df7 100644 --- a/modules/luci-base/po/bg/base.po +++ b/modules/luci-base/po/bg/base.po @@ -2404,7 +2404,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/bn_BD/base.po b/modules/luci-base/po/bn_BD/base.po index fa9f589381..90a6135278 100644 --- a/modules/luci-base/po/bn_BD/base.po +++ b/modules/luci-base/po/bn_BD/base.po @@ -2378,7 +2378,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/ca/base.po b/modules/luci-base/po/ca/base.po index 4d576b72aa..61c972427d 100644 --- a/modules/luci-base/po/ca/base.po +++ b/modules/luci-base/po/ca/base.po @@ -2453,8 +2453,8 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." -msgstr "Descarta les respostes RFC1918 des de dalt." +"Discard upstream responses containing {rfc_1918_link} addresses." +msgstr "Descarta les respostes {rfc_1918_link} des de dalt." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/cs/base.po b/modules/luci-base/po/cs/base.po index 506ed5449f..f7f33b02f3 100644 --- a/modules/luci-base/po/cs/base.po +++ b/modules/luci-base/po/cs/base.po @@ -2466,9 +2466,9 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" -"Vyřadit upstream odpovědi, které obsahují <a href=\"%s\">RFC1918</a> adresy." +"Vyřadit upstream odpovědi, které obsahují {rfc_1918_link} adresy." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/da/base.po b/modules/luci-base/po/da/base.po index d67949a0d3..b484ee3b6d 100644 --- a/modules/luci-base/po/da/base.po +++ b/modules/luci-base/po/da/base.po @@ -2506,9 +2506,9 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" -"Kassér upstream svar, der indeholder <a href=\"%s\">RFC1918</a>-adresser." +"Kassér upstream svar, der indeholder {rfc_1918_link}-adresser." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/de/base.po b/modules/luci-base/po/de/base.po index 768295cbd8..cff7f1cb99 100644 --- a/modules/luci-base/po/de/base.po +++ b/modules/luci-base/po/de/base.po @@ -2528,9 +2528,9 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" -"Verwerfen von Upstream-Antworten, die <a href=\"%s\">RFC1918</a> Adressen " +"Verwerfen von Upstream-Antworten, die {rfc_1918_link} Adressen " "enthalten." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/el/base.po b/modules/luci-base/po/el/base.po index b93f6cd448..73bb287e13 100644 --- a/modules/luci-base/po/el/base.po +++ b/modules/luci-base/po/el/base.po @@ -2441,8 +2441,8 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." -msgstr "Αγνόησε τις απαντήσεις ανοδικής ροής RFC1918." +"Discard upstream responses containing {rfc_1918_link} addresses." +msgstr "Αγνόησε τις απαντήσεις ανοδικής ροής {rfc_1918_link}." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/en/base.po b/modules/luci-base/po/en/base.po index 048c1a6f83..104fe839eb 100644 --- a/modules/luci-base/po/en/base.po +++ b/modules/luci-base/po/en/base.po @@ -2383,7 +2383,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/es/base.po b/modules/luci-base/po/es/base.po index 7a2214dac8..03e81621dd 100644 --- a/modules/luci-base/po/es/base.po +++ b/modules/luci-base/po/es/base.po @@ -2550,10 +2550,9 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" -"Descarta respuestas ascendentes que contengan direcciones <a " -"href=\"%s\">RFC1918</a>." +"Descarta respuestas ascendentes que contengan direcciones {rfc_1918_link}." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/fi/base.po b/modules/luci-base/po/fi/base.po index 6775ac014a..8f931a41fb 100644 --- a/modules/luci-base/po/fi/base.po +++ b/modules/luci-base/po/fi/base.po @@ -2446,8 +2446,8 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." -msgstr "Hylkää ulkoverkosta tulevat RFC1918-vastaukset." +"Discard upstream responses containing {rfc_1918_link} addresses." +msgstr "Hylkää ulkoverkosta tulevat {rfc_1918_link}-vastaukset." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/fr/base.po b/modules/luci-base/po/fr/base.po index ddd95b6169..906a319c3c 100644 --- a/modules/luci-base/po/fr/base.po +++ b/modules/luci-base/po/fr/base.po @@ -2541,10 +2541,9 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" -"Rejeter les réponses en amont contenant des adresses <a href=\"%s\">RFC1918</" -"a>." +"Rejeter les réponses en amont contenant des adresses {rfc_1918_link}." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/he/base.po b/modules/luci-base/po/he/base.po index 140d7359ac..711b0cf4a2 100644 --- a/modules/luci-base/po/he/base.po +++ b/modules/luci-base/po/he/base.po @@ -2398,7 +2398,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/hi/base.po b/modules/luci-base/po/hi/base.po index d2ffc8d45a..af7908fa32 100644 --- a/modules/luci-base/po/hi/base.po +++ b/modules/luci-base/po/hi/base.po @@ -2380,7 +2380,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/hu/base.po b/modules/luci-base/po/hu/base.po index 6a23a75252..73cccb26be 100644 --- a/modules/luci-base/po/hu/base.po +++ b/modules/luci-base/po/hu/base.po @@ -2455,8 +2455,8 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." -msgstr "Külső <a href=\"%s\">RFC1918</a> válaszok elvetése." +"Discard upstream responses containing {rfc_1918_link} addresses." +msgstr "Külső {rfc_1918_link} válaszok elvetése." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/it/base.po b/modules/luci-base/po/it/base.po index 3c174fe626..644085c0c5 100644 --- a/modules/luci-base/po/it/base.po +++ b/modules/luci-base/po/it/base.po @@ -2536,9 +2536,9 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" -"Scarta risposte upstream che contengono indirizzi <a href=\"%s\">RFC1918</a>." +"Scarta risposte upstream che contengono indirizzi {rfc_1918_link}." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/ja/base.po b/modules/luci-base/po/ja/base.po index 5937a1b4f6..35c573981c 100644 --- a/modules/luci-base/po/ja/base.po +++ b/modules/luci-base/po/ja/base.po @@ -2459,8 +2459,8 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." -msgstr "アップストリームのRFC1918応答を破棄します。" +"Discard upstream responses containing {rfc_1918_link} addresses." +msgstr "アップストリームの{rfc_1918_link}応答を破棄します。" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/ko/base.po b/modules/luci-base/po/ko/base.po index 5163e5f70c..50d12664ca 100644 --- a/modules/luci-base/po/ko/base.po +++ b/modules/luci-base/po/ko/base.po @@ -2435,7 +2435,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/lt/base.po b/modules/luci-base/po/lt/base.po index 9f9eb9dea9..8944104379 100644 --- a/modules/luci-base/po/lt/base.po +++ b/modules/luci-base/po/lt/base.po @@ -2424,7 +2424,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/mr/base.po b/modules/luci-base/po/mr/base.po index c94c926b62..5bc66be8fe 100644 --- a/modules/luci-base/po/mr/base.po +++ b/modules/luci-base/po/mr/base.po @@ -2378,7 +2378,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/ms/base.po b/modules/luci-base/po/ms/base.po index e86d83ae73..43392d4903 100644 --- a/modules/luci-base/po/ms/base.po +++ b/modules/luci-base/po/ms/base.po @@ -2383,7 +2383,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/nb_NO/base.po b/modules/luci-base/po/nb_NO/base.po index 57e62e1f53..d6cdda0e95 100644 --- a/modules/luci-base/po/nb_NO/base.po +++ b/modules/luci-base/po/nb_NO/base.po @@ -2420,8 +2420,8 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." -msgstr "Forkast oppstrøms RFC1918 svar." +"Discard upstream responses containing {rfc_1918_link} addresses." +msgstr "Forkast oppstrøms {rfc_1918_link} svar." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/nl/base.po b/modules/luci-base/po/nl/base.po index e786b68270..2b99b48503 100644 --- a/modules/luci-base/po/nl/base.po +++ b/modules/luci-base/po/nl/base.po @@ -2509,9 +2509,9 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" -"Negeer upstream-antwoorden die <a href=\"%s\">RFC1918</a>-adressen bevatten." +"Negeer upstream-antwoorden die {rfc_1918_link}-adressen bevatten." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/pl/base.po b/modules/luci-base/po/pl/base.po index 80dfc95d83..e04e508037 100644 --- a/modules/luci-base/po/pl/base.po +++ b/modules/luci-base/po/pl/base.po @@ -2528,9 +2528,9 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" -"Odrzuć odpowiedzi nadrzędne zawierające adresy <a href=\"%s\">RFC1918</a>." +"Odrzuć odpowiedzi nadrzędne zawierające adresy {rfc_1918_link}." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/pt/base.po b/modules/luci-base/po/pt/base.po index 232e61477e..e166810ce4 100644 --- a/modules/luci-base/po/pt/base.po +++ b/modules/luci-base/po/pt/base.po @@ -2527,7 +2527,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" "Descarta as respostas dos servidores externos que conteem endereços <a " "href=\"%s\">RFC1918</a>." diff --git a/modules/luci-base/po/pt_BR/base.po b/modules/luci-base/po/pt_BR/base.po index d803aff6c9..756941df39 100644 --- a/modules/luci-base/po/pt_BR/base.po +++ b/modules/luci-base/po/pt_BR/base.po @@ -2533,7 +2533,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" "Descarta as respostas dos servidores externos contendo endereços <a " "href=\"%s\">RFC1918</a>." diff --git a/modules/luci-base/po/ro/base.po b/modules/luci-base/po/ro/base.po index abd4599f53..801faee280 100644 --- a/modules/luci-base/po/ro/base.po +++ b/modules/luci-base/po/ro/base.po @@ -2525,7 +2525,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" "Respingeți răspunsurile din amonte care conțin adrese <a " "href=\"%s\">RFC1918</a>." diff --git a/modules/luci-base/po/ru/base.po b/modules/luci-base/po/ru/base.po index cfc7e3f0fa..439a9af987 100644 --- a/modules/luci-base/po/ru/base.po +++ b/modules/luci-base/po/ru/base.po @@ -2546,7 +2546,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" "Отбрасывать ответы вышестоящего сервера, содержащие адреса <a " "href=\"%s\">RFC1918</a>." diff --git a/modules/luci-base/po/sk/base.po b/modules/luci-base/po/sk/base.po index bc35b94af3..7920758dbc 100644 --- a/modules/luci-base/po/sk/base.po +++ b/modules/luci-base/po/sk/base.po @@ -2481,7 +2481,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/sv/base.po b/modules/luci-base/po/sv/base.po index eae2ea38d4..fa75106fd0 100644 --- a/modules/luci-base/po/sv/base.po +++ b/modules/luci-base/po/sv/base.po @@ -2405,7 +2405,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/tr/base.po b/modules/luci-base/po/tr/base.po index 95bc1646bc..7e33a94696 100644 --- a/modules/luci-base/po/tr/base.po +++ b/modules/luci-base/po/tr/base.po @@ -2505,9 +2505,9 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" -"<a href=\"%s\">RFC1918</a> adreslerini içeren yukarı akış yanıtlarını yoksay." +"{rfc_1918_link} adreslerini içeren yukarı akış yanıtlarını yoksay." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/uk/base.po b/modules/luci-base/po/uk/base.po index 5752859534..ef75e79ce7 100644 --- a/modules/luci-base/po/uk/base.po +++ b/modules/luci-base/po/uk/base.po @@ -2532,10 +2532,9 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" -"Відкиньте відповіді вгору за течією, що містять адреси <a " -"href=\"%s\">RFC1918</a>." +"Відкиньте відповіді вгору за течією, що містять адреси {rfc_1918_link}." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/ur/base.po b/modules/luci-base/po/ur/base.po index 343b606da5..5a642bbab0 100644 --- a/modules/luci-base/po/ur/base.po +++ b/modules/luci-base/po/ur/base.po @@ -2377,7 +2377,7 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." +"Discard upstream responses containing {rfc_1918_link} addresses." msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 diff --git a/modules/luci-base/po/vi/base.po b/modules/luci-base/po/vi/base.po index 8d42c3e4d6..77371d4579 100644 --- a/modules/luci-base/po/vi/base.po +++ b/modules/luci-base/po/vi/base.po @@ -2499,8 +2499,8 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." -msgstr "Hủy các phản hồi ngược dòng chứa địa chỉ <a href=\"%s\">RFC1918</a>." +"Discard upstream responses containing {rfc_1918_link} addresses." +msgstr "Hủy các phản hồi ngược dòng chứa địa chỉ {rfc_1918_link}." #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/zh_Hans/base.po b/modules/luci-base/po/zh_Hans/base.po index dba7e9c7c7..ff1ac1bc1c 100644 --- a/modules/luci-base/po/zh_Hans/base.po +++ b/modules/luci-base/po/zh_Hans/base.po @@ -2435,8 +2435,8 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." -msgstr "丢弃包含 <a href=\"%s\">RFC1918 </a>地址的上游响应。" +"Discard upstream responses containing {rfc_1918_link} addresses." +msgstr "丢弃包含 {rfc_1918_link}地址的上游响应。" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-base/po/zh_Hant/base.po b/modules/luci-base/po/zh_Hant/base.po index 4729c9ccae..d1950bae38 100644 --- a/modules/luci-base/po/zh_Hant/base.po +++ b/modules/luci-base/po/zh_Hant/base.po @@ -2432,8 +2432,8 @@ msgstr "" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js:348 msgid "" -"Discard upstream responses containing <a href=\"%s\">RFC1918</a> addresses." -msgstr "丟棄包含 <a href=\"%s\">RFC1918</a> 地址的上游響應。" +"Discard upstream responses containing {rfc_1918_link} addresses." +msgstr "丟棄包含 {rfc_1918_link} 地址的上游響應。" #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/interfaces.js:198 #: modules/luci-mod-network/htdocs/luci-static/resources/view/network/wireless.js:716 diff --git a/modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js b/modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js index c05d8a278a..96e8621fbc 100644 --- a/modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js +++ b/modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js @@ -261,6 +261,18 @@ return view.extend({ networks = hosts_duids_pools[3], m, s, o, ss, so; + let noi18nstrings = { + etc_hosts: '<code>/etc/hosts</code>', + not_found: '<code>Not found</code>', + + }; + + function customi18n(template, values) { + if (!values) + values = noi18nstrings; + return template.replace(/\{(\w+)\}/g, (match, key) => values[key] || match); + }; + m = new form.Map('dhcp', _('DHCP and DNS'), _('Dnsmasq is a lightweight <abbr title="Dynamic Host Configuration Protocol">DHCP</abbr> server and <abbr title="Domain Name System">DNS</abbr> forwarder.')); @@ -282,15 +294,17 @@ return view.extend({ s.taboption('general', form.Flag, 'domainneeded', _('Domain required'), - _('Do not forward DNS queries without dots or domain parts.')); - + _('Never forward DNS queries which lack dots or domain parts.') + '<br />' + + customi18n(_('Names not in {etc_hosts} are answered {not_found}.') ) + ); s.taboption('general', form.Flag, 'authoritative', _('Authoritative'), _('This is the only DHCP server in the local network.')); - s.taboption('general', form.Value, 'local', - _('Local server'), - _('Never forward matching domains and subdomains, resolve from DHCP or hosts files only.')); + o = s.taboption('general', form.Value, 'local', + _('Resolve these locally'), + _('Never forward these matching domains or subdomains; resolve from DHCP or hosts files only.')); + o.placeholder = '/internal.example.com/private.example.com/example.org'; s.taboption('general', form.Value, 'domain', _('Local domain'), @@ -298,20 +312,16 @@ return view.extend({ o = s.taboption('general', form.Flag, 'logqueries', _('Log queries'), - _('Write received DNS queries to syslog.')); + _('Write received DNS queries to syslog.') + ' ' + _('Dump cache on SIGUSR1, include requesting IP.')); o.optional = true; o = s.taboption('general', form.DynamicList, 'server', _('DNS forwardings'), - _('List of upstream resolvers to forward queries to.')); + _('Forward specific domain queries to specific upstream servers.')); o.optional = true; - o.placeholder = '/example.org/10.1.2.3'; + o.placeholder = '/*.example.org/10.1.2.3'; o.validate = validateServerSpec; - function customi18n(template, values) { - return template.replace(/\{(\w+)\}/g, (match, key) => values[key] || match); - }; - o = s.taboption('general', form.DynamicList, 'address', _('Addresses'), _('Resolve specified FQDNs to an IP.') + '<br />' + @@ -345,7 +355,7 @@ return view.extend({ o = s.taboption('general', form.Flag, 'rebind_protection', _('Rebind protection'), - _('Discard upstream responses containing <a href="%s">RFC1918</a> addresses.').format('https://www.rfc-editor.org/rfc/rfc1918') + '<br />' + + customi18n(_('Discard upstream responses containing {rfc_1918_link} addresses.') ) + '<br />' + _('Discard also upstream responses containing <a href="%s">RFC4193</a>, Link-Local and private IPv4-Mapped <a href="%s">RFC4291</a> IPv6 Addresses.').format('https://www.rfc-editor.org/rfc/rfc4193', 'https://www.rfc-editor.org/rfc/rfc4291')); o.rmempty = false; |
