diff options
| author | Paul Donald <newtwen@gmail.com> | 2023-12-04 05:16:23 +0100 |
|---|---|---|
| committer | Paul Donald <newtwen@gmail.com> | 2023-12-04 23:40:37 +0100 |
| commit | a9e8e39de1480d9f03cfd3fd6c5ac301225a62b6 (patch) | |
| tree | 59ab375e647a25939aa3da5baac0892de7e0bbf6 | |
| parent | 4643a7d233fb021d95f113e33b460ee2c99d739c (diff) | |
Merge pull request #6712 from systemcrash/discard_text
luci-mod-network: Extend helptext for RFC1918 rebind_protection
(cherry picked from commit d75626efcdf322a2c16559c11d5a53bab6dbd8a3)
| -rw-r--r-- | modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js b/modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js index c62231fe20..3bb92c57e5 100644 --- a/modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js +++ b/modules/luci-mod-network/htdocs/luci-static/resources/view/network/dhcp.js @@ -309,7 +309,8 @@ return view.extend({ o = s.taboption('general', form.Flag, 'rebind_protection', _('Rebind protection'), - _('Discard upstream responses containing <a href="%s">RFC1918</a> addresses.').format('https://datatracker.ietf.org/doc/html/rfc1918')); + _('Discard upstream responses containing <a href="%s">RFC1918</a> addresses.').format('https://www.rfc-editor.org/rfc/rfc1918') + '<br />' + + _('Discard also upstream responses containing <a href="%s">RFC4193</a>, Link-Local and private IPv4-Mapped <a href="%s">RFC4291</a> IPv6 Addresses.').format('https://www.rfc-editor.org/rfc/rfc4193', 'https://www.rfc-editor.org/rfc/rfc4291')); o.rmempty = false; o = s.taboption('general', form.Flag, 'rebind_localhost', |
